Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 20, 2026 - 16:00 UTC
Scheduled
Dear Valued Customer,
This message provides an update on our ongoing network infrastructure enhancement work.
Building on the progress made in the earlier phases, we are now entering the final phase of this initiative. This stage focuses on completing the remaining segment of the rollout, which requires a defined additional window to complete carefully.
Maintenance window: July 20 – August 7, 2026
What to Expect: Work will continue in a phased, controlled manner. Services remain fully operational, though you may occasionally notice brief variations in API response times as deployments occur.
What This Means for You: - Services remain fully operational throughout this period - No action is required on your part - Our engineering and support teams continue to monitor performance metrics closely
Our Commitment: We are committed to maintaining the high level of service you expect. Should you notice any unexpected behavior or have questions, please contact our API Support team at apisupport@weather.com.
We appreciate your understanding and continued partnership.
Best regards, TWC API Support
Posted Jul 18, 2026 - 03:03 UTC
This scheduled maintenance affects: New Standard Weather Data Package, Severe Weather Package, Recent Lightning Strikes Package, Seasonal Forecast Package, Probabilistic Forecast Package, Agriculture Package, Renewables Package, History on Demand Package, Cleaned Historical Package, Aviation Core Package, Aviation Enhanced Core Package, Aviation Enroute Package, Media Data APIs, WeatherUnderground PWS APIs, and Location Services.