Degraded Performance - History on Demand

Incident Report for The Weather Company Data APIs

Resolved

API services have been restored and missing data backfills have completed. All data should now be available. Thank you.
Posted May 21, 2026 - 17:33 UTC

Identified

The issue has been identified, and service is actively being restored. We are observing signs of recovery. Missing historical data is in the process of being re-ingested. Thank you.
Posted May 21, 2026 - 13:54 UTC

Investigating

We are currently experiencing degraded performance with the History on Demand (/v3/wx/hod/r1/direct), Historical Data for Analytical Tools (/v3/wx/observations/historical/analytical/r2) APIs.

Our engineers are actively triaging the issue.

Thank you for your patience.
Posted May 21, 2026 - 13:44 UTC
This incident affected: History on Demand Package.