Degraded Performance - PWS APIs

Incident Report for The Weather Company Data APIs

Resolved

This and the previous update were posted with an incorrect status. This update confirms this issue has the correct resolved status.
Posted Mar 16, 2026 - 17:47 UTC

Update

This issue is now resolved. PWS stations will now show as expected in location services. This and the previous update were posted with an incorrect status.
Posted Mar 16, 2026 - 17:27 UTC

Update

This issue is now resolved. PWS stations will now show as expected in location services.
Posted Mar 16, 2026 - 17:22 UTC

Update

We have resolved the issue involving Personal Weather Station (PWS) query responses in our location services.
Posted Mar 13, 2026 - 16:49 UTC

Investigating

We are currently experiencing issues with PWS query responses in location services, which may result in some PWS stations not appearing.

Location service APIs impacted:
/v3/location/point
/v3/location/search
/v3/location/near
v3/location/boundary

The team is actively working on a fix.

We appreciate your patience and will provide updates as they become available.
Posted Mar 11, 2026 - 17:46 UTC
This incident affected: WeatherUnderground PWS APIs and Location Services.